Delay in Outbound Email Delivery

Incident Report for MailChannels

Resolved

This incident has been resolved. The queue has been cleared. If you are facing any issues, please reach out to Support.
Posted Oct 09, 2024 - 15:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2024 - 15:14 PDT

Update

We are continuing to work on the issue. We are clearing out backed-up emails in our queues.
Posted Oct 09, 2024 - 14:20 PDT

Identified

We have identified delay in outbound email delivery. We are working on fixing it.
Posted Oct 09, 2024 - 13:49 PDT
This incident affected: Outbound Filtering (SMTP Service).