Delay in Email Deliveries
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 12:27 PDT
Monitoring
We identified an issue with our downstream network provider. A fix has been implemented and we are monitoring.
Posted Apr 21, 2020 - 09:44 PDT
Investigating
We are currently experiencing delays in email delivery to the recipients. No mails are lost. We are investigating the issue.
Posted Apr 21, 2020 - 09:17 PDT
This incident affected: Outbound Filtering (SMTP Service).