Increased Errors in Cloud Service
Incident Report for MailChannels Cloud
Resolved
This incident has been resolved.
Posted about 1 year ago. Oct 18, 2017 - 14:37 PDT
Monitoring
The issue seems to be resolved now. We are monitoring the situation.
Posted about 1 year ago. Oct 18, 2017 - 14:23 PDT
Identified
AWS Oregon is experiencing network connectivity issues resulting in errors connecting to our cloud service.

AWS Status: http://status.aws.amazon.com/

We will keep you posted.
Posted about 1 year ago. Oct 18, 2017 - 14:09 PDT