High SMTP Connection Latency
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 13:54 PDT
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted Aug 29, 2023 - 10:45 PDT