Delays in email deliveries
Incident Report for MailChannels Cloud
Resolved
The queues are now at normal levels.

If you are still seeing any issues, please contact support@mailchannels.com
Posted Oct 24, 2019 - 16:18 PDT
Monitoring
We have identified the issue that was causing our queues to increase. A fix has been deployed. Queues are now at normal levels. We are continuing to monitor
Posted Oct 24, 2019 - 16:01 PDT
Investigating
We are investigating reports of delays in email deliveries to recipients. We are seeing increased queues. We will provide an update as soon as we have more information.
Posted Oct 24, 2019 - 15:06 PDT
This incident affected: MailChannels Outbound Filtering - SMTP Service.