Host & Domain consoles are down
Incident Report for MailChannels
Resolved
This incident has now been resolved. We identified that this was caused by a failed deployment.
Posted May 11, 2020 - 10:47 PDT
Investigating
We are currently investigating the issue.
Posted May 11, 2020 - 10:44 PDT
This incident affected: Inbound Filtering (Domain Console) and Outbound Filtering (Host Console).