Cloud Console is down
Incident Report for MailChannels Cloud
Resolved
A bad image was deployed. We have now fixed the issue and the console is up now.

Please contact support@mailchannels.com if you are still seeing any issues.
Posted 5 months ago. Jun 19, 2018 - 14:03 PDT
Identified
We are currently investigating the issue.

There are no issues with the email processing.
Posted 5 months ago. Jun 19, 2018 - 13:50 PDT
This incident affected: MailChannels Outbound Web Console.