Some customers are unable to login to the Inbound domain console
Incident Report for MailChannels
Resolved
We have identified the underlying cause and have fixed it.
Posted Nov 27, 2019 - 09:11 PST
Identified
We have identified an issue where some customers are unable to login to the Inbound domain console through the host console. We are working on resolving the issue.
Posted Nov 27, 2019 - 06:48 PST
This incident affected: Outbound Filtering (Host Console).