DNS issues
Incident Report for MailChannels
Resolved
The issues are now resolved. Please don't hesitate to contact Support if you have any issues (support@mailchannels.com)
Posted Feb 20, 2017 - 09:53 PST
Monitoring
We have tweaked our systems and the issue is now resolved. We are continuing to monitor the situation.
Posted Feb 20, 2017 - 07:28 PST
Identified
We are seeing increased rates of DNS errors. We are investigating.
Posted Feb 20, 2017 - 06:02 PST