SMTP Service Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with authenticating to the MailChannels Outbound Filtering - SMTP Service .

If you continue to have issues, please contact support@mailchannels.com
Posted Jul 11, 2022 - 01:04 PDT
Investigating
Severity Level: 2

We are currently experiencing a degraded performance on account of intermittent authentication failures to our service.

Our operations team is working to identify the root cause and implement a solution. Mail delivery for all MailChannels Cloud users may be intermittent as a result.

We will send an additional update in 60 minutes or as soon as we have more information to share.
Posted Jul 11, 2022 - 00:48 PDT
This incident affected: Outbound Filtering (SMTP Service).