Some quarantine digests are not being sent.
Incident Report for MailChannels
Resolved
This incident has been resolved. Recipients who had messages quarantined between 2022-11-07 21:50:10 and 2022-11-08 21:50:10 (UTC), and whose quarantine digest is normally delivered between 22:00 and 02:00 (UTC), may not have received a quarantine digest even though there are messages in the quarantine. Recipients who may have been affected should log in to https://app.mailchannels.com to check their quarantined messages.
Posted Nov 08, 2022 - 18:59 PST
Investigating
For inbound filtering users who have the filtering action sent to 'Quarantine', quarantine digests are not being sent. Normal mail flow does not appear to be affected. Until this issue is resolved, you can check https://app.mailchannels.com for quarantined messages.

We are investigating the issue.
Posted Nov 08, 2022 - 16:57 PST
This incident affected: Inbound Filtering (SMTP Service).