Delay in Email Deliveries
Incident Report for MailChannels Cloud
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 30, 2019 - 12:53 PDT
Update
Queues are back to normal. If you are having any further issues, please contact support@mailchannels.com
Posted 18 days ago. Sep 30, 2019 - 12:43 PDT
Monitoring
We have identified delays in email delivery due to network issue with our upstream network provider. The emails are being delivered but with a small delay. Some emails are sitting in our queue and will be delivered soon.

We are monitoring and will post an update once the queue has been cleared.
Posted 18 days ago. Sep 30, 2019 - 11:55 PDT
This incident affected: MailChannels Outbound Filtering - SMTP Service.