SMTP Service Degraded Performance
Incident Report for MailChannels Cloud
Resolved
A networking failure caused message delivery from our queues to the recipient servers to fail. This meant the messages were retained in our queues for longer than normal. No messages were lost.

The problem has now been resolved, and messages are being delivered. It may take a few minutes for all of the queued messages to be delivered to their destinations.
Posted Nov 08, 2019 - 10:01 PST
Investigating
We are currently experiencing a degraded performance in our Mailchannels Cloud SMTP service.

Our operations team is working to identify the root cause and implement a solution. Mail delivery for all MailChannels Cloud users may be intermittent.

We will send an additional update in 60 minutes or as soon as we have more information to share.
Posted Nov 08, 2019 - 09:18 PST
This incident affected: MailChannels Outbound Filtering - SMTP Service.