Messages sent via outbound filtering are being delayed
Incident Report for MailChannels
Resolved
The issue has been resolved, messages are no longer being delayed. All messages have been flushed from our internal queues. If Any messages have not been delivered, or you have any other concerns, please open a ticket at support@mailchannels.com.
Posted May 21, 2022 - 08:31 PDT
Monitoring
We have resolved the delivery delays. We are continuing to monitor the status of the service, as well as flushing queued messages that were caught by the delays.
Posted May 21, 2022 - 07:33 PDT
Identified
We have identified the source of the issue, and are working on a fix.
Posted May 21, 2022 - 07:02 PDT
Update
We are continuing to investigate this issue.
Posted May 21, 2022 - 06:57 PDT
Investigating
Currently, many messages sent via our outbound filtering system are being delayed. We are investigating the issue.
Posted May 21, 2022 - 05:31 PDT
This incident affected: Outbound Filtering (SMTP Service).