Inbound Service Email Delivery Issue
Incident Report for MailChannels Cloud
Resolved
The issue has been fixed and mail flow is normal now.

If you have any concerns or questions about the outage, please don't hesitate to reach out to us at support@mailchannels.com
Posted Nov 29, 2019 - 16:19 PST
Investigating
We have identified an issue with one of the components that is causing inbound emails to be temporary failed. We are working on resolving this at the highest priority.
Posted Nov 29, 2019 - 16:04 PST
This incident affected: MailChannels Inbound Filtering - SMTP Service.