Some Email API webhooks are delayed.

Incident Report for MailChannels

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 00:00 PST

Monitoring

During a database migration operation, a database became overloaded, resulting in the loss of Email API events. Between 22:00 and 22:45 PST, webhooks for Email API events were not sent.

The issue has been corrected, and we are monitoring the affected systems.
Posted Feb 19, 2026 - 23:30 PST

Investigating

We're aware of an incident that is causing some webhooks for Email API events to be delayed. We are investigating.
Posted Feb 19, 2026 - 22:51 PST
This incident affected: Email API.