High SMTP Connection Latency
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 16:57 PST
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted Feb 22, 2024 - 13:36 PST