Slow SMTP Transactions for Inbound Filtering
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Feb 03, 2025 - 20:54 PST
Monitoring
New database nodes are online, and connections are balanced. SMTP transaction duration is dropping. We are continuing to monitor the issue.
Posted Feb 03, 2025 - 20:33 PST
Identified
We have identified a potential cause of the delay as an overloaded database node. We are rebalancing connections to the database, and adding more nodes.
Posted Feb 03, 2025 - 20:17 PST
Investigating
We have been alerted to slow SMTP transactions on the Inbound Filtering system. We are working to identify the source of the problem.
Posted Feb 03, 2025 - 20:01 PST
This incident affected: Inbound Filtering (SMTP Service).