mailchannels.com website is down

Incident Report for MailChannels

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 13:27 PST

Identified

"mailchannels.com" website is down at the moment. We are working with our service provider to fix the issue.

There is no impact on any of the consoles or email delivery.
Posted Nov 07, 2025 - 10:15 PST