Inbound Cloud - Quarantine Release issues
Incident Report for MailChannels
Resolved
We have identified the issue and will be reaching out to all customers impacted by this in a separate email.
Posted Jul 16, 2020 - 22:37 PDT
Investigating
We are investigating reports that some users have been unable to release recent emails from quarantine. This only impacts the inbound cloud customers that have quarantine enabled. We will continue to post updates.
Posted Jul 16, 2020 - 14:00 PDT