Intermittent Outbound SMTP Authentication Failure

Incident Report for MailChannels

Resolved

This incident has been resolved. There are no further issues.

If you need assistance with anything, please feel free to reach out to support@mailchannels.com
Posted Nov 20, 2020 - 16:06 PST

Monitoring

We have identified the issue and a workaround has been implemented. We are continuing to monitor.
Posted Nov 20, 2020 - 15:03 PST

Investigating

We are currently investigating elevated levels of outbound smtp authentication failures.
Posted Nov 20, 2020 - 12:54 PST
This incident affected: Outbound Filtering (SMTP Service).