Primary web site www.mailchannels.com is down because of issues with Cloudflare
Incident Report for MailChannels
Resolved
The issues at Cloudflare seem to be resolving
Posted Nov 03, 2023 - 13:09 PDT
Monitoring
Our primary web site (www.mailchannels.com) is down because of an issue with Cloudflare that is causing widespread problems across the internet. Our web console and email delivery services are unaffected by this problem
Posted Nov 03, 2023 - 06:57 PDT