Delay in Outbound Email Delivery
Incident Report for MailChannels
Resolved
All old mails in queue have now been delivered. Some mails might have bounced back with a "lost connection" error message.
Posted Nov 17, 2021 - 14:39 PST
Update
Mails are still clearing out of the queues.
Posted Nov 17, 2021 - 11:30 PST
Monitoring
Mails in the queue is being delivered quickly now. New emails are being delivered quickly. Some mails might have bounced back with a "lost connection" error message.
Posted Nov 17, 2021 - 10:00 PST
Investigating
We have identified an issue with outbound service resulting in delayed email delivery. We have deployed a fix. It will take some time for the queues to clear out.

We will post an update once the queue has been completely cleared out.
Posted Nov 17, 2021 - 09:47 PST
This incident affected: Outbound Filtering (SMTP Service).