Delays in message delivery.
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 14:01 PST
Monitoring
A fix has been implemented. We are monitoring for any further issues.
Posted Nov 12, 2024 - 08:18 PST
Identified
We are seeing delayed processing of both inbound and outbound transactions. We have identified the cause, and are currently working on a fix.
Posted Nov 12, 2024 - 07:44 PST
This incident affected: Outbound Filtering (SMTP Service) and Inbound Filtering (SMTP Service).