Delays in message delivery.
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Aug 03, 2024 - 05:28 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 03, 2024 - 04:53 PDT
Monitoring
We have identified the issue as a problem with network connectivity to our egress nodes. Traffic has been redirected away from the affected nodes.

Mail delivery is functioning normally, however, there may be larger than normal delays as we work through the queues.
Posted Aug 03, 2024 - 04:29 PDT
Investigating
We are aware of delays in message delivery, for both inbound and outbound filtering. We are investigating the issue.
Posted Aug 03, 2024 - 04:17 PDT
This incident affected: Outbound Filtering (SMTP Service) and Inbound Filtering (SMTP Service).