Outbound SMTP Service Degraded Performance

Incident Report for MailChannels

Resolved

The backed up emails have been delivered. Please reach out to support@mailchannels.com if you have questions.
Posted Sep 24, 2025 - 06:08 PDT

Update

We are continuing to deliver the backed up mails in our queue. We are continuing to monitor and will post an update when the backed up emails are delivered.
Posted Sep 24, 2025 - 05:25 PDT

Investigating

We are currently experiencing degraded performance in our Mailchannels Cloud SMTP service. There is a delay in delivering emails to the destination. We have emails sitting in our queue waiting for delivery. We are continuing to monitor and will post an update when the backed up emails are delivered.
Posted Sep 24, 2025 - 04:00 PDT
This incident affected: Outbound Filtering (SMTP Service).