Outage
Incident Report for MailChannels
Resolved
All the queued mail should be delivered now. If you are still seeing any issues, please contact support@mailchannels.com
Posted Jul 28, 2023 - 11:46 PDT
Monitoring
A fix has been implemented , we are delivering email of both inbound and outbound services from redundant infrastructure. We still have some mail queued in our servers that will be cleared out shortly.
Posted Jul 28, 2023 - 10:57 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 28, 2023 - 10:52 PDT
Update
We are processing outbound filtering again , it will catch up shortly
Posted Jul 28, 2023 - 10:22 PDT
Identified
The issue has been identified and a fix is being implemented. The network of one of our upstream providers went down and as a result, mails were queued in our servers.
Posted Jul 28, 2023 - 10:21 PDT
This incident affected: Outbound Filtering (SMTP Service) and Inbound Filtering (SMTP Service).