Issue sending mails to mailchannels.com

Incident Report for MailChannels

Resolved

This incident has been resolved.
Posted Jan 03, 2025 - 08:30 PST

Investigating

We are currently investigating issues sending emails to the mailchannels.com domain.
Posted Jan 03, 2025 - 08:22 PST