Email Delivery Issues to Microsoft (hotmail.com/outlook.com/msn.com/live.com)
Incident Report for MailChannels
Resolved
Emails to Microsoft destinations are now back to normal. Please contact Support if you are still seeing any issues delivering email.
Posted Oct 07, 2024 - 17:50 PDT
Identified
We are experiencing temporary issues delivering to Microsoft destinations such as hotmail.com/outlook.com/msn.com/live.com etc. We are in touch with Microsoft to resolve the problem as quickly as possible. The messages are being temporary failed by Microsoft. At the moment, we advise the customers to either wait until we resolve the issue or find alternative delivery options for that traffic while we work with our contacts at Microsoft to get it resolved.
Posted Oct 07, 2024 - 10:16 PDT
This incident affected: Outbound Filtering (SMTP Service).