Log Search is backed up

Incident Report for MailChannels

Resolved

We have resolved the issue.
Posted Apr 10, 2026 - 11:59 PDT

Investigating

We are investigating an issue with log search. The logs are backed up in our queue. There are no issues with email delivery.
Posted Apr 10, 2026 - 09:10 PDT
This incident affected: Outbound Filtering (Host Console).