Delay in outbound email delivery
Incident Report for MailChannels
Resolved
Queued emails have now been delivered. If you continue to see any issues, please reach out to us at support@mailchannels.com
Posted Jun 03, 2024 - 09:17 PDT
Update
Most of the queued emails have been delivered. We will update again when all the queued emails have been delivered.
Posted Jun 03, 2024 - 08:48 PDT
Monitoring
A fix has been implemented and the queued emails are being delivered as quickly as possible.
Posted Jun 03, 2024 - 08:07 PDT
Investigating
We are investigating an issue causing a delay in outbound email delivery. Emails are queued in our system, and we are trying to deliver them as quickly as possible
Posted Jun 03, 2024 - 07:22 PDT
This incident affected: Outbound Filtering (SMTP Service).