High SMTP Connection Latency
Incident Report for MailChannels Cloud
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 09, 2017 - 22:59 PST
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted about 1 year ago. Nov 09, 2017 - 22:23 PST