Customer Console is Unavailable
Incident Report for MailChannels
Resolved
The subscription management service has been repaired, and Customer Console is now operational.
Posted Jan 16, 2017 - 02:35 PST
Investigating
Due to a failure in the subscription management service, the Customer Console is currently unavailable. Mail delivery is not affected.
Posted Jan 16, 2017 - 01:39 PST