High SMTP Connection Latency
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 13:40 PDT
Update
Recovery is now complete. Emails in the queues have been cleared out.

If you are continuing to see any issues, please reach out to us at support@mailchannels.com
Posted Mar 28, 2023 - 13:40 PDT
Monitoring
Emails are still backed up in our queues and are being delivered slowly.

If you are continuing to see any issues, please reach out to us at support@mailchannels.com
Posted Mar 28, 2023 - 12:13 PDT
Identified
We have implemented a fix. Emails are still backed up in our queues and are being delivered slowly.
Posted Mar 28, 2023 - 11:44 PDT
Update
We have identified the root cause and are working on fixing the issue. At this point, email delivery is delayed or backed up in your mail servers.
Posted Mar 28, 2023 - 10:47 PDT
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted Mar 28, 2023 - 09:58 PDT
This incident affected: Outbound Filtering (SMTP Service).