High SMTP Connection Latency

Incident Report for MailChannels

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 12:31 PDT

Investigating

We are currently investigating higher than normal connection latency that might have an impact on outbound email delivery services.
Posted Sep 10, 2025 - 07:58 PDT
This incident affected: Outbound Filtering (SMTP Service).