Inbound Cloud Domain Console Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with the MailChannels Inbound Domain Console. The Domain Console is up now.
Posted May 27, 2022 - 11:58 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with MailChannels Inbound Domain Console. We are currently investigating.
Posted May 27, 2022 - 11:55 PDT
This incident affected: Inbound Filtering (Domain Console).