Issue with support ticketing system
Incident Report for MailChannels
Resolved
The denial of service attack has been mitigated.
Posted Oct 21, 2016 - 17:49 PDT
Monitoring
Our support ticketing system provider, Zendesk, is experiencing an outage caused by a very large denial of service attack on the global DNS. For more information on this issue as it evolves, you may visit https://status.zendesk.com/.

The URL https://mailchannels.zendesk.com is not functioning at the present time; however, email sent to support@mailchannels.com is being received and will be processed by our support team as quickly as possible. We apologize for the inconvenience.

A good summary of the DNS problem has been written up on Gizmodo at this URL if you wish to learn more: http://gizmodo.com/this-is-probably-why-half-the-internet-shut-down-today-1788062835
Posted Oct 21, 2016 - 10:26 PDT