Messages are delayed
Incident Report for MailChannels
Resolved
The incident has been resolved. All the queued messages have been delivered. If you need any assistance, please reach out to us at support@mailchannels.com
Posted Sep 01, 2022 - 11:51 PDT
Monitoring
The issue seems to have resolved, and mail is flowing normally. It may take some time to deliver all queued messages, until then, there may continue to be some delays. We are monitoring the situation, and continuing to investigate the root cause.
Posted Sep 01, 2022 - 10:37 PDT
Investigating
We are currently experiencing delays in both inbound and filtering. We are investigating the issue.
Posted Sep 01, 2022 - 08:48 PDT
This incident affected: Outbound Filtering (SMTP Service) and Inbound Filtering (SMTP Service).