Intermittent SMTP Connection Failure
Incident Report for MailChannels
Resolved
The incident has been resolved.
Posted Jul 11, 2022 - 03:53 PDT
Monitoring
We have identified the issue as a faulty deployment that has now been reverted. We are continuing to monitor for any issues.

If there are mails backed up in your queues, you may try flushing the queues.
Posted Jul 11, 2022 - 03:50 PDT
Investigating
We are currently investigating reports of intermittent failures connecting to the SMTP service. We are looking into it.
Posted Jul 11, 2022 - 03:13 PDT
This incident affected: Outbound Filtering (SMTP Service).