High SMTP Connection Latency
Incident Report for MailChannels Cloud
Resolved
Monitor inaccurately showing smtp.mailchannnels.ch as having an issues
Posted about 1 year ago. Nov 14, 2017 - 13:55 PST
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted about 1 year ago. Nov 14, 2017 - 08:30 PST