Increased Delays in Mail Delivery
Incident Report for MailChannels
Resolved
All mail queues have been cleared. This incident is resolved.
Posted Jul 23, 2021 - 00:19 PDT
Monitoring
We have implemented a workaround to avoid the failed networking component. Delayed messages are now being delivered. It may take some time before all delayed messages have been delivered. We are continuing to monitor the situation.
Posted Jul 22, 2021 - 22:57 PDT
Identified
We have identified a networking issue that is causing delivery delays. We are attempting to route around the issue.

No messages have been lost.
Posted Jul 22, 2021 - 22:45 PDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 22:20 PDT
This incident affected: Inbound Filtering (SMTP Service) and Outbound Filtering (SMTP Service).