Increased False Positives Rate
Incident Report for MailChannels Cloud
Resolved
We have identified and fixed all the issues with false positives. Please contact support@mailchannels.com if you are still seeing any issues.
Posted 3 months ago. Sep 06, 2017 - 13:51 PDT
Monitoring
We have identified the issue and are now monitoring to ensure it has been completely resolved.
Posted 3 months ago. Sep 06, 2017 - 12:54 PDT
Investigating
We have seen an increase in the number of false positive reports over the last 2 hours. We are working on identifying the cause of false positives. If you are having any issues, please contact our support team at support@mailchannels.com.

Severity Level: 3
Posted 3 months ago. Sep 06, 2017 - 09:03 PDT