Cloud Console Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with the cloud console.
Posted Sep 20, 2017 - 01:08 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with cloud console. We are currently investigating.
Posted Sep 20, 2017 - 00:20 PDT