Outbound Cloud Console Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted Apr 17, 2021 - 17:29 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted Apr 17, 2021 - 16:25 PDT
This incident affected: Outbound Filtering (Host Console).