SMTP Service Degraded Performance
Incident Report for MailChannels
Resolved
The issue has been resolved. All mails in the queue has been drained out.
Posted Mar 24, 2022 - 13:59 PDT
Update
We are continuing to monitor for any further issues. Mails are still clearing our from our queues.
Posted Mar 24, 2022 - 12:54 PDT
Monitoring
A fix has been implemented and we are monitoring the status. Mails in our queues are clearing out slowly. We will update again when the queue has been cleared out.
Posted Mar 24, 2022 - 11:48 PDT
Investigating
We are currently experiencing a degraded performance in our Mailchannels Cloud SMTP service. We have identified increased latency in email delivery.

Our operations team is working to identify the root cause and implement a solution. Mail delivery for all MailChannels Cloud users may be intermittent.

We will send an additional update in 60 minutes or as soon as we have more information to share.
Posted Mar 24, 2022 - 10:27 PDT
This incident affected: Outbound Filtering (SMTP Service).