Reseller API Degradation
Incident Report for MailChannels Cloud
Resolved
We have now identified and resolved the performance issues with the Reseller API.

If you have any questions or concerns, please contact MailChannels Support (support@mailchannels.com)
Posted 3 months ago. Aug 01, 2017 - 14:29 PDT
Investigating
Our automated systems have detected possible performance issues with the Reseller API. We are currently investigating and will provide an update soon.
Posted 3 months ago. Aug 01, 2017 - 14:28 PDT