Inbound Cloud Console Degraded Performance
Incident Report for MailChannels Cloud
Resolved
We have identified and fixed the issues with the inbound cloud console.
Posted 3 months ago. Jan 24, 2019 - 10:33 PST
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with cloud console. We are currently investigating.
Posted 3 months ago. Jan 24, 2019 - 10:32 PST
This incident affected: MailChannels Inbound Domain Console.