Issue with mailchannels.com emails
Incident Report for MailChannels Cloud
Resolved
We identified an issue with sending emails to mailchannels.com domain. This has now been resolved and everything is back to normal now.

Some of the support tickets (mails to support@mailchannels.com) would have been rejected in the last few hours. If so, please resubmit them.
Posted 24 days ago. Oct 27, 2018 - 07:40 PDT