High SMTP Connection Latency
Incident Report for MailChannels Cloud
Resolved
The incident was tracked down to a transient routing issue between Amazon Web Services and one of our egress traffic providers. Steps have been taken to reduce the likelihood of a recurrence of this problem.
Posted Nov 08, 2019 - 14:19 PST
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted Nov 08, 2019 - 11:27 PST
This incident affected: MailChannels Outbound Filtering - SMTP Service.