High SMTP Connection Latency
Incident Report for MailChannels Cloud
Resolved
We have now identified and resolved the performance issues with the Reseller API.

If you have any questions or concerns, please contact MailChannels Support (support@mailchannels.com)
Posted about 1 year ago. Nov 09, 2017 - 22:09 PST
Update
Console access has been restored now.
Posted about 1 year ago. Nov 09, 2017 - 21:52 PST
Identified
Mail flow has been restored. The mails should be clearing from your queues now. Please flush your queues.
Posted about 1 year ago. Nov 09, 2017 - 21:21 PST
Update
Our automated systems have detected possible performance issues with the Reseller API. We are currently investigating and will provide an update soon.
Posted about 1 year ago. Nov 09, 2017 - 18:28 PST
Update
Our automated systems have detected possible performance issues with the Reseller API. We are currently investigating and will provide an update soon.
Posted about 1 year ago. Nov 09, 2017 - 18:28 PST
Update
Our automated systems have detected possible performance issues with the Reseller API. We are currently investigating and will provide an update soon.
Posted about 1 year ago. Nov 09, 2017 - 18:28 PST
Investigating
Severity Level: 3

We are currently investigating higher than normal connection latency that might have an impact on email delivery services.
Posted about 1 year ago. Nov 09, 2017 - 17:58 PST